Speed Dial Ctrl-Shortcut keys stopped working on my Firefox browser

With the above settings, they now work.

When they didn’t work, this was the setting:

Full answer:

I did a few things, but I think my problem was that I had changed this setting the ‘Ctrl’, and thus ‘Ctrl’ key got reserved (see SS attached).

Also, I was trying to open diff speeddials thru KB shortcuts while sitting in the speed dial tab itself (earlier they did work this way also). But later I found (after changing the above said ‘Ctrl’ key setting to ‘Shift’ or to ‘Alt’) that even though my Speed Dial KB S Keys didn’t work from this tab, they worked (or started to work now) from all other tabs.